cancel
Showing results for 
Search instead for 
Did you mean: 

Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

Occasional Visitor

Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

Here is the issue that i am running into- We are trying to silently upgrade our pulse client from 5.3.1161 to 9.0.1151. I can script the upgrade and push it through SCCM successfully. 

The issue that i am noticing is that the connections that are configured are not coming over. 

We have not seen this issue before with upgrades. 

 

Any thoughts on backing up file that stores the active connections?

 

If this topic is out there please point me in the right direction. 

 

7 REPLIES 7
New Contributor

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

how did you handle the devices that had an active vpn connection? is there a way to properly dectect and script it to only proceed if no session is running?

New Contributor

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

or maybe just check device ip if i'ts on the vpn subnet?

Moderator
Moderator

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

Check for the "VpnTunnelEstablished" value:

 

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Pulse Secure\Pulse\State\VpnTunnelEstablished

 

0 - Not connected.

1 - Connected.

Moderator

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

connections configured on the appliance or on the client?
do you see the same behavior when not using SCCM? does this happen on all machines or only SCCM?
New Contributor

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

so i can do this in a batch file but how can i proceed maybe using errorlevel or a compare?

reg query "HKLM\SOFTWARE\WOW6432Node\Pulse Secure\Pulse\State" /v VpnTunnelEstablished

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Pulse Secure\Pulse\State
VpnTunnelEstablished REG_DWORD 0x0

Moderator
Moderator

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

Sorry! Never used scripts before..😅 Anyway, I believe... it's going to be if-then-else statement.

New Contributor

Re: Pulse Secure 5.3.1161 upgrade to 9.0.1151 and losing Connections

SELECT * FROM Win32_NetworkAdapterConfiguration WHERE IPEnabled = true and Description = "Juniper Networks Virtual Adapter"