cancel
Showing results for 
Search instead for 
Did you mean: 

Pulse Secure Linux UI

Occasional Contributor

Pulse Secure Linux UI

Hello,
do you know if Pulse Secure Linux UI is supported on Debian OS type ?
I'm trying to install and launch UI but still blocked on :
root@debian:/usr/local/pulse# /usr/local/pulse/pulseUi
/usr/local/pulse/pulseUi: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

even after installing libwebkitgtk-1.0-0 and libwebkitgtk-1.0-common libraries.
Version: 8.2R4
Regards.
Menant
5 REPLIES 5
Moderator

Re: Pulse Secure Linux UI

Hi Menant,

There is a UI debian Linux client in 8.2R4. If you're running 8.2R4, you can get it from the Maintenance > System > Installers.

You can find more info here https://kb.pulsesecure.net/articles/Pulse_Secure_Article/KB40126

Regards,
Ashur
Please remember to mark solved once the thread is resolved. Kudos are also appreciated.
Occasional Contributor

Re: Pulse Secure Linux UI

Hi Ashur,
yes that's exactly what i'm testing.
As I previously said, it's working well on Ubuntu distrib.
But when I'm trying the same on a Debian, it's not possible to install dependency packages using the PulseClient.sh script :
/usr/local/pulse/PulseClient.sh install_dependency_packages

I don't succeed to install these dependency packages manually.

Regards.

Menant
New Contributor

Re: Pulse Secure Linux UI

Hi

Same problem here, trying to use the client on Ubuntu 16.04 and ran into exact same problem, and installing the required library did not help either.

Would be great to have someone look at this issue?
New Contributor

Re: Pulse Secure Linux UI

ok, this is how I solved the problem, there were two issues:
-need to indicate where the library is
-pulse seems to want the 32 bits version...

Install the 32 its version:
sudo apt-get install libwebkitgtk-1.0-0:i386

Export the path:
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/i386-linux-gnu
export LD_LIBRARY_PATH

And then it works, but these are dirty workarounds, and hopefully the Pulse developers will fix instead the code and propose a more elegant solution!
New Member

Re: Pulse Secure Linux UI

for x86_64 please run

sudo apt-get install libwebkitgtk-1.0-0

it worked for me

Thanks