cancel
Showing results for 
Search instead for 
Did you mean: 

Pulse Secure Setup Client installation error -100 : InternetSetCookie failed

SOLVED
Highlighted
New Contributor

Pulse Secure Setup Client installation error -100 : InternetSetCookie failed

Hi,

 

I'm a new user and I am setting up the software for the first time. The website I use, checks for the Application Launcher installation and opns it which in turn tries to run the Pulse Secure Setup. While doing so, I am facing the two errors below:-

 

From the Pulse Secure Setup-

System Error: Please sign in and try again. If the problem continues, please contact your system administrator

 

after clicking ok, i receive the below from Application Launcher-

Detected an internal error: Please retry. If the issue persists, contact your system administrator.

 

I have narrowed down the issue from the logs to the setPreAuthCookie() method where it is unable to set the cookie. I have copied the logs below:

 

PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:288 - 'DSSetupRequestHandler::invoke()' *****************************setPreauthCookie()*****************************
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:407 - 'DSSetupRequestHandler::getNamedCookieFromParam()' nameSmiley Very HappySPREAUTH=
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupParameters.cpp:86 - 'DSSetupParameters::getParameter()' Cookies length: 583
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:420 - 'DSSetupRequestHandler::getNamedCookieFromParam()' valueSmiley Very HappySPREAUTH=ad0325d8%3A8AuWXUnkCAABAAAAlSD%2FJw4AaClIxxbYeNZnjrOERUJYcwgEu1vpFT0Wxre1zQaIqyjoSndPrXa592OTM2CUdQdGnwyURULuQRfb5iiF6l5Pk4bUvb2Xs4v%2BUQQrjpYzC0aWdrvmUgwUaI6%2FxOzGkbyN0WxP6UvNBmHl0pGvmDfs68WAwZ5SLdhWDdsCZyllBCyX8K5fIcKVQiHCkUaYqvJ2O7Mh8%2Fs1K8h0fluqKYvhH3G%2BrIgxRK1xVP26zsD2W44BJUJyk8QLbimzH2AsieMg%2FFgJjolziw4uifJqUIcfhQKP9bpA%2F8yXChVAxlAymqEnDmql6OfGxhsibw5NJTjiU4XB21cY1c3B%2FxVzRj3GeWTM%2Bw38q%2FJr7pQB6VeF7tLxlJoFswq4kkMorGzNemuaZi5onif1jTZPCw%3D%3D
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:432 - 'DSSetupRequestHandler::setPreauthCookie()' m_preauthCookieSmiley Very HappySPREAUTH=ad0325d8%3A8AuWXUnkCAABAAAAlSD%2FJw4AaClIxxbYeNZnjrOERUJYcwgEu1vpFT0Wxre1zQaIqyjoSndPrXa592OTM2CUdQdGnwyURULuQRfb5iiF6l5Pk4bUvb2Xs4v%2BUQQrjpYzC0aWdrvmUgwUaI6%2FxOzGkbyN0WxP6UvNBmHl0pGvmDfs68WAwZ5SLdhWDdsCZyllBCyX8K5fIcKVQiHCkUaYqvJ2O7Mh8%2Fs1K8h0fluqKYvhH3G%2BrIgxRK1xVP26zsD2W44BJUJyk8QLbimzH2AsieMg%2FFgJjolziw4uifJqUIcfhQKP9bpA%2F8yXChVAxlAymqEnDmql6OfGxhsibw5NJTjiU4XB21cY1c3B%2FxVzRj3GeWTM%2Bw38q%2FJr7pQB6VeF7tLxlJoFswq4kkMorGzNemuaZi5onif1jTZPCw%3D%3D
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupParameters.cpp:88 - 'DSSetupParameters::getParameter()' Host=some link
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:461 - 'DSSetupRequestHandler::setPreauthCookie()' host=some link; cookieSmiley Very HappySPREAUTH=ad0325d8%3A8AuWXUnkCAABAAAAlSD%2FJw4AaClIxxbYeNZnjrOERUJYcwgEu1vpFT0Wxre1zQaIqyjoSndPrXa592OTM2CUdQdGnwyURULuQRfb5iiF6l5Pk4bUvb2Xs4v%2BUQQrjpYzC0aWdrvmUgwUaI6%2FxOzGkbyN0WxP6UvNBmHl0pGvmDfs68WAwZ5SLdhWDdsCZyllBCyX8K5fIcKVQiHCkUaYqvJ2O7Mh8%2Fs1K8h0fluqKYvhH3G%2BrIgxRK1xVP26zsD2W44BJUJyk8QLbimzH2AsieMg%2FFgJjolziw4uifJqUIcfhQKP9bpA%2F8yXChVAxlAymqEnDmql6OfGxhsibw5NJTjiU4XB21cY1c3B%2FxVzRj3GeWTM%2Bw38q%2FJr7pQB6VeF7tLxlJoFswq4kkMorGzNemuaZi5onif1jTZPCw%3D%3D; path=/dana-na/; expires=Fri, 02-Oct-2020 10:56:35 GMT; secure
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:466 - 'DSSetupRequestHandler::setPreauthCookie()' InternetSetCookie(https://some link) failed: 0
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:598 - 'DSSetupRequestHandler::handleError()' Starting: -100
PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupRequestHandler.cpp:340 - 'DSSetupRequestHandler::invoke()' *****************************setPreauthCookie() retCode=-100
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:549 - 'DSInvokeSetupClient::sendAndRecv()' bytesRecv 26
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:552 - 'DSInvokeSetupClient::sendAndRecv()' received: "DSSETUP_RETURN_CODE=-100


PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:557 - 'DSInvokeSetupClient::sendAndRecv()' End of buffer reached: return DSSETUP_ERR_SUCCESS
PulseSetupClient.exe PulseSetupClient p55992 t14A6C JuniperSetupSocket.cpp:118 - 'DSSetupClientInstallLock()' ReleaseMutex(DSSETUPCLIENT_MUTEX)
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:428 - 'DSInvokeSetupClient::invokeSetupClient()' Ending 0
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:183 - 'DSInvokeSetupClient::invoke()' ReceiveSmiley Very HappySSETUP_RETURN_CODE=-100


PulseSetupClient.exe PulseSetupClient p55992 t14A6C dsSetupParameters.cpp:88 - 'DSSetupParameters::getParameter()' ProductName=
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 JuniperSetupUtils.cpp:965 - 'dsRetrieveNameValue()' DSSETUP_RETURN_CODE=-100
PulseSetupClient.exe PulseSetupClient p55992 t14A6C JuniperSetupSocket.cpp:310 - 'JuniperSetupSocket::run()' Wait for connection...
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:197 - 'DSInvokeSetupClient::invoke()' return:-100
PulseApplicationLauncher.exe DSInvokeSetupClient p56696 t13D70 dsInvokeSetupClient.cpp:224 - 'DSInvokeSetupClient::invokeEx()' invoke failed -100
PulseApplicationLauncher.exe PSAL p56696 t13D70 dsSetupClientHelper.cpp:218 - 'DSSetupClientHelper::invokeSetupDll()' retCode=-100
PulseApplicationLauncher.exe PSAL p56696 t13D70 dsSetupClientHelper.cpp:88 - 'DSSetupClientHelper::invoke()' ended, retCode=-100
PulseApplicationLauncher.exe PSAL p56696 t13D70 applauncher.cpp:759 - 'Psal::AppLauncher' clientHelper.invoke() failed: -100
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Contributor

Re: Pulse Secure Setup Client installation error -100 : Internet Set Cookie failed

I believe I was able to find the root cause today for the issue in our environment. The issue lies within the WebCache file for Windows - apparently both IE and Pulse borrow the settings in this for their WinINet processes to connect to the internet. When windows syspreps the image, this ends up in the Default profile and ends up getting stamped for all users. I was able to find a bunch of others online (other apps) with similar issues. You can script a fix, running as the local user which consists of stopping the CacheTask service :

 

Get-ScheduledTask CacheTask | Stop-Scheduled Task

Remove-Item $env:LOCALAPPDATA\Microsoft\Windows\WebCache\WebCacheV01.dat -Force

Get-ScheduledTask CacheTask | Start-ScheduledTask

 

Note you may have to issue a taskkill for taskhostw.exe as well (it keeps a lock on WebCacheV01.DAT otherwise).

 

The long term fix is when you sysprep your images, make sure that your sysprep process excludes the "$env:LOCALAPPDATA\Microsoft\Windows\WebCache" directory on new images. Windows will automatically build this on its own when a new user logs in, so it doesnt need to even be in the DEFAULT profile.

 

Hope this helps someone - that was almost 3 months of troubleshooting. The way I spotted this was to use procmon (Sysinternals) to capture the Access Denied errors on another users profile trying to write to the InetCookies EDB file in the local administrator (which we use for the capture).

 

 

View solution in original post

11 REPLIES 11
Highlighted
Moderator

Re: Pulse Secure Setup Client installation error -100 : InternetSetCookie failed

Hi there,

Can you please run the PulseSetupClient.exe as admin and check the behaviour?

Go to the program location, program properties, compatibility -- run as administrator.
PCS Expert
Pulse Connect Secure Certified Expert
Highlighted
Moderator

Re: Pulse Secure Setup Client installation error -100 : InternetSetCookie failed

How do you deploy the OS on the machine? Manually installation or using any tools like SysPrep?
PCS Expert
Pulse Connect Secure Certified Expert
Highlighted
New Contributor

Re: Pulse Secure Setup Client installation error -100 : InternetSetCookie failed

Hi Ray,

 

Thanks for your response. When I run the SetupClient as an admin, it shows up in the task manager but is just waiting on something and doesn't install. Is it possible the issue is with the setup (32 bit) vs my Windows 10 machine being 64 bit?

Highlighted
Moderator

Re: Pulse Secure Setup Client installation error -100 : InternetSetCookie failed

Hi there,

Being a 32bit application should not cause any issues while running on 64bit OS.

I believe you're trying to run the setup client installer as admin, hence please run the setup client application as admin which was already installed on your machine. You should find the application under C:\Users\Username\Appdata\Roaming\Pulse Secure\Setup Client\Pulsesetupclient.exe
PCS Expert
Pulse Connect Secure Certified Expert
Highlighted
Occasional Visitor

Re: Pulse Secure Setup Client installation error -100 : Internet Set Cookie failed

I am als o facing the same error. It was running smoothly earlier and suddenly started to give error. Can you please suggesrt something?

Highlighted
Moderator

Re: Pulse Secure Setup Client installation error -100 : Internet Set Cookie failed

Is it working when logged in using a different windows profile or user profile? Please uninstall all Setup Client related components and try again. If not resolved, please provide the debuglogs for review.

PCS Expert
Pulse Connect Secure Certified Expert
Highlighted
New Contributor

Re: Pulse Secure Setup Client installation error -100 : Internet Set Cookie failed

I am also seeing the identical issue in our environment. We are using Windows 10 Build 1909, IE version - 11.959.18362.0 (either 32 or 64 bit makes no difference). In the debug log, we see the setPreAuthCookie method is also throwing error -100. The user is a local admin and the site is in the Internet zone, however we also tried Local Intranet with all default IE security settings with no luck.

 

Interestingly, I saw a comment on if this is a captured image; it is in our case, using Microsoft Deployment Tools. If we install a Windows 10 OEM image, then the issue cannot be re-created, so we believe this is related to the capture image process in MDT. Since this impacts most of our environment since we use deployed images, I am trying to understand what the root cause/change is when using a captured image.

 

The only lead we have so far is this method is being called on the non-working machines, however it doesn't appear to throw the -100 error until after this function:

00231,09 2020/08/14 08:53:31.787 1 admin.user PulseSetupClient.exe PulseSetupClient p1344 t798 dsSetupRequestHandler.cpp:471 - 'DSSetupRequestHandler::setPreauthCookie()' InternetSetCookie(https://our_site) failed: 0

00175,09 2020/08/14 08:53:31.787 3 admin.user PulseSetupClient.exe PulseSetupClient p1344 t798 dsSetupRequestHandler.cpp:603 - 'DSSetupRequestHandler::handleError()' Starting: -100

 

Any chance the OP or anyone else has found a solution to this issue?

Highlighted
Moderator

Re: Pulse Secure Setup Client installation error -100 : Internet Set Cookie failed

what version of the client are you using?
what version of the server are you using?
if you have not installed 9.1R7.1 installer service, please try with that on the client; otherwise, please create a support case
Moderator

Re: Pulse Secure Setup Client installation error -100 : Internet Set Cookie failed

It sounds alot similar to the Sysprep issue, are you using SysPrep tool for Windows deployment?

 

https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/sysprep--system-preparation--o...

PCS Expert
Pulse Connect Secure Certified Expert