cancel
Showing results for 
Search instead for 
Did you mean: 

PulseSecure Client Doesn't work with Ubuntu 18.04

New Contributor

PulseSecure Client Doesn't work with Ubuntu 18.04

Dear Everybody,

 

I recently updated to Ubuntu 18.04.

I reinstalled the PulseSecure client as provide by my university to be able to connect to my workstation, when working outside the university.

 

However, it doesn't work.

When I'm running

/usr/local/pulse/PulseClient.sh

I get the following:

/usr/local/pulse/pulsesvc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

However, libstdc++ is installed:

locate libstdc++.so.6 

gives:

/snap/core/4486/usr/lib/x86_64-linux-gnu/libstdc++.so.6
/snap/core/4486/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
/snap/core/4486/usr/share/gdb/auto-load/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21-gdb.py
/snap/core/4650/usr/lib/x86_64-linux-gnu/libstdc++.so.6
/snap/core/4650/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
/snap/core/4650/usr/share/gdb/auto-load/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21-gdb.py
/snap/skype/33/usr/lib/x86_64-linux-gnu/libstdc++.so.6
/snap/skype/33/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
/snap/skype/33/usr/share/gdb/auto-load/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21-gdb.py
/usr/lib/x86_64-linux-gnu/libstdc++.so.6
/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.25
/usr/share/gdb/auto-load/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.25-gdb.py

Did anybody encounter the same problem and knows how to fix it?

That would be very helpful.

 

Thanks in advance.

 

Best,

Marcus

 

 

2 REPLIES 2
Moderator

Re: PulseSecure Client Doesn't work with Ubuntu 18.04

There is a new GUI-based installer.  Does your university have access to it?  Please ask IT, they should be able to download it either from my.pulsesecure.net or directly from there Pulse Connect Secure device.

 

Not sure what instructions you have for installation, but we have it detailed here:

https://kb.pulsesecure.net/articles/Pulse_Secure_Article/KB40126

Please remember to mark solved once the thread is resolved. Kudos are also appreciated.
Tags (2)
New Contributor

Re: PulseSecure Client Doesn't work with Ubuntu 18.04

Finally I could resolve the problem with the help of the IT-support at my university.

 

Eventually, all we needed to do was to set-up a 32-bit architecture on my machine (so eventually I have 32-bit and 64-bit in parallel(-> how to multiarch)) and install the 32-bit version of the mentioned libstdc++.so.6 library.

 

Cheers,

Marcus