cancel
Showing results for 
Search instead for 
Did you mean: 

Ubuntu - Failed to load module "canberra-gtk-module"

Occasional Visitor

Ubuntu - Failed to load module "canberra-gtk-module"

I have this so Linux david-TM1703 4.15.0-118-generic #119-Ubuntu SMP Tue Sep 8 12:30:01 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

 

i have this problem

 

Gtk-Message: 13:11:38.991: Failed to load module "canberra-gtk-module"
20201016131139.96347 pulsesvc[p15086.t15086] pulseui.error Executing JScript: AddCollapseData('Disconnected', '', '', '') (pulseUi.cpp:467)
20201016131139.96588 pulsesvc[p15086.t15086] pulseui.error Unable to load Json Parser, message: ReferenceError: Can't find variable: id (pulseUi.cpp:731)

(pulseUi:15086): libsoup-CRITICAL **: 13:11:41.299: soup_cookie_jar_get_cookies: assertion 'SOUP_IS_COOKIE_JAR (jar)' failed

(pulseUi:15086): libsoup-CRITICAL **: 13:11:41.317: soup_cookie_jar_get_cookies: assertion 'SOUP_IS_COOKIE_JAR (jar)' failed

(pulseUi:15086): libsoup-CRITICAL **: 13:11:41.325: soup_cookie_jar_get_cookies: assertion 'SOUP_IS_COOKIE_JAR (jar)' failed

(pulseUi:15086): libsoup-CRITICAL **: 13:11:41.334: soup_cookie_jar_get_cookies: assertion 'SOUP_IS_COOKIE_JAR (jar)' failed

(pulseUi:15086): libsoup-CRITICAL **: 13:11:41.336: soup_cookie_jar_get_cookies: assertion 'SOUP_IS_COOKIE_JAR (jar)' failed
20201016131207.755380 pulsesvc[p15086.t15086] pulseui.error Error opening connections file (pulseUi.cpp:534)
Violación de segmento (`core' generado)

1 REPLY 1
Highlighted
Frequent Contributor

Re: Ubuntu - Failed to load module "canberra-gtk-module"

Hi @xqno 

 

That is just a gtk module which can be installed with

apt install libcanberra-gtk-module

but that is a GTK theme and can be ignored.

 

Probably you miss this from README file

    Launch UI from the terminal:
        1) Append /usr/local/pulse to LD_LIBRARY_PATH
            example: export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pulse

        2) Launch the UI by executing the below command 
            /usr/local/pulse/pulseUi

It is better to lauch Pulse Secure via Activity Manager in Gnome.