cancel
Showing results for 
Search instead for 
Did you mean: 

ps-pulse-linux-9.1r3.1 client doen't work on CentOS 8

Highlighted
New Member

ps-pulse-linux-9.1r3.1 client doen't work on CentOS 8

Hello,
I am using ps-pulse-linux-9.1r3.1-b107-centos-rhel-64-bit-installer.rpm on CentOS 8 and pulse ui fails to run. 
I also ran /usr/local/pulse/PulseClient_x86_64.sh install_dependency_packages before running pulseUI. 
However, it looks like there is a dependency to an old libwebkitgtk-1.0.so.0

$ ./pulseUi
./pulseUi: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

I tried downloading it and bunch of dependency that goes with it ( e.g libicui18n.so.65, libwebp.so.4, libicuuc.so.50, etc... ) but wasn't able to get it work. After all that I ended up getting this error:

$ ./pulseUi
./pulseUi: symbol lookup error: /usr/local/pulse/libwebkitgtk-1.0.so.0: undefined symbol: _ZNK3WTF6String5splitEDsbRNS_6VectorIS0_Lm0ENS_15CrashOnOverflowEEE

Can you please help me out?