cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade to vtm from 9.7 to 10.4 brocade

Highlighted
Occasional Contributor

Upgrade to vtm from 9.7 to 10.4 brocade

Hi ,

 

We have to upgarde the vtm from 9.7 to 10.4.

 

VTM is on vm .

 

I have that doubt abou the application firwall .  Main Tab of the aplication firewall is Greyed out i can not do anything but the in the system tab , application firewall is enabled .

 

so what is the procedure of the upgarde.

 

we have the GLB service also so any other precaution need to taken ?

 

Please share your experince to upgarde .

 

Rgrd,

Nishant 

 

10 REPLIES
Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

I have also doubt that when we are upgarding the  vtm from 9.7 to 10.4

 

During the export of config there is option of to include applicaiton firewall so what we need to do with that option

 

Second same for the import.

 

I have tried to export via not including the application firewall and also impor with the same way but automatically the firewall is enabled.

Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

When we tried the follwing step to upgarde the VTM frm 9.7 to 10.4 

 

i tried to find out folder to take the backup of application as mentioned by BRocade on below location but not able to find the folder zeusafm..

 

so i thought the application firewall is not enabled.

 

/opt/zeus/zeusafm/current/var/lib/config.db 

 

 

Few screen shot 9.7 riverbed  is attached:  screenshot1 and screenshot2

 

When i upload the backup from the Rivbed 9.7 to 10.4 i am getting the error as attched in error.png ..applicaiton firewall is automatically ON , tried to disable the same but no luck.

 

 

 

 

 

 

Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

Please see this screenshot ..I explain everthing on this 

Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

One more screen shot ..may be help ful..

 

Please let us know how we can go head with this 

Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

@Nishant

 

I'm not a big expert with this application, however I've reviewed some Release Notes and Manuals, and I believe if I understand correct, you need first to upgrade to Intermediate Release in you case first to v9.9 and then to 10.x or higher.

 

should I'm wrong, please ignore my post.

 

thank you!

 

 

 

Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

I am also not sure but i have the riverbed appliance 9.7 i have upgarde it 10.1 brocade but on that there is no application firewall.

 

one month ago i have disccused with support they sugested me go  head with 9.7 to 10.4 ..

do you have link or article which says that ...

 

 

 

Its rivebed VTM(Load balancer) 9.7 and i have to upgarde it to 10.4 brocade  ..

Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

I am referfing this procedure for the upgarde ..

In many cases, it is desirable to upgrade a virtual appliance by deploying a virtual appliance at the newer version and importing the old configuration. For example, the size of the traffic manager disk image was increased in version 9.7, and deploying a new virtual appliance lets a customer take advantage of this larger disk. This article documents the procedure for deploying a new virtual appliance with the old configuration in common scenarios.

These instructions describe how to upgrade and reinstall Brocade Virtual Traffic Manager appliance instances (either in a cluster or standalone appliances). For instructions on upgrading on other platforms, please refer to Upgrading Stingray Traffic Manager.

Upgrading a standalone Virtual Appliance

This process will replace a standalone virtual appliance with another virtual appliance with the same configuration (including migrating network configuration). Note that the Brocade Virtual Traffic Manager Cloud Getting Started Guide contains instructions for upgrading a standalone EC2 instance from version 9.7 onwards; if upgrading from a version prior to 9.7 and using the Stingray Application Firewall (now Brocade Virtual Web Application Firewall) these instructions must be followed to correctly back up and restore any firewall configuration.

1. Make a backup of the traffic manager configuration (See section "System > Backups" in the Brocade Virtual Traffic Manager User Manual), and export it.
2. If you are upgrading from a version prior to 9.7 and are using the Stingray Application Firewall, back up the Stingray Application Firewall configuration
1. Log on to a command line
2. Run /opt/zeus/stop-zeus
3. Copy /opt/zeus/zeusafm/current/var/lib/config.db off the appliance.
3. Shut down the original appliance.
4. Deploy a new appliance with the same network interfaces as the original.
5. If you backed up the application firewall configuration earlier, restore it here onto the new appliance, before you restore the traffic manager configuration:
1. Copy the config.db file to /opt/zeus/stingrayafm/current/var/lib/config.db (overwriting the original)
2. Check that the owner on the config.db file is root, and the mode is 0644.
6. Import and restore the traffic manager configuration via the UI.
7. If you have application firewall errors
1. Use the Diagnose page to automatically fix any configuration errors
2. Reset the Traffic Manager software.
Occasional Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

@Nishant

 

->do you have link or article which says that ...

 

No.

 

as mentioned in my preview post, I find some info in Release Notes and Guide.

 

and yes you are correct, accordly the Rel. Notes intermediate Upgrade is required for Rel. 9.6 or earlier.

 

Contributor

Re: Upgrade to vtm from 9.7 to 10.4 brocade

@nishant - Did you already raise a support case for this one? That's probably the best route forward on this one, and we can post an update to this thread when we have discussed.