Showing results for 
Search instead for 
Did you mean: 

zcli error when running


zcli error when running

I have installed zxtm as root on a linux box and afterwards tried to run zcli.  It works fine as root.  When I ran zinstall I selected a user zesuadmin and group zeus as owner and group of user to start/stop zeus.

[zeusadmin@cbl06427app05 bin]$ ./zcli

Please enter your password for user 'admin' on the local traffic manager

Connected to

Error with deveditioninfo:

There was a problem communicating with machine localhost.  Failed to find control port.

Use of uninitialized value in concatenation (.) or string at ./zcli line 274.

Frequent Contributor

Re: zcli error when running

Hi Paul,

You'll need to run the zcli tool as root; it needs to be able to access some of the traffic manager configuration files which are only readable by root.

The error you get is odd and I think it's due to a recently-discovered bug specific to the development edition - I've just tested with a recent software and virtual appliance install and in each case, I get the much more helpful error message:

[owen@athene ~]$ ZEUSHOME=/usr/local/zeus /usr/local/zeus/zxtm/bin/zcli

Please enter your password for user 'admin' on the local traffic manager

Can't read traffic manager's admin config: Permission denied

If ever you need to speak with support, you can refer to bug22620.

The username and group that you provided at install refers to the user and group that the traffic manager processes (zeus.zxtm children) run as, and don't have any bearing on the permissions of the configuration.  The various Stingray (zeus) management processes run as root, and the configuration (which can contain sensitive information) is stored as root-only.